Mandatory Upgrade v1.0.0.x > v2.0.0.0 Xerus

Adeptio Core v2.0.0.0 Xerus

Before upgrading make sure to have wallet.dat and adeptio.conf backups!

Before doing an upgrade. Take a look at troublesooting

HOT masternode no longer supported. It is not safe to keep coins in VPS!

Not fair masternode owners will be banned from masternode rewards due to running multiple mn on one IP.

Make sure to have flag in adeptio.conf - enablezeromint=0

Cold masternode setup guides can be found here: https://wiki.adeptio.cc/books/masternode---vps-setup-guide

is a mandatory upgrade to address bugs, rebrand new features & enhancements. Please note - "storADE" system is now required in order to start a masternode. However, due to high risk of hard fork this step postponed in v2.1.0.0 version.


Old version nodes & wallets (v1.0.0.x) slowly be rejected by the network.

 


Regular GUI (Graphical User Interface) Users:

If you are running an older GUI version, shut it down. Wait until it has completely shut down (which might take a few minutes), then run the new release.

 

Master-node operators:

New wallet version requires libevent-dev dependency. Please install by typing in the terminal:

sudo apt-get install libevent-dev -y

 

Ubuntu 16.04 LTS procedure:

Stop the adeptiod thought the systemd or kill the process: 

sudo systemctl stop adeptiocore.service && pkill adeptiod

Check if adeptiod stopped:

sudo systemctl status adeptiocore.service && pgrep adeptiod

If the process stopped continue:

cd ~/
rm -f ~/adeptio-cli ~/adeptiod
cp -fr ~/.adeptio/ ~/.adeptio_backup/
wget https://github.com/adeptio-project/adeptio/releases/download/v2.0.0.0/adeptiod-v2.0.0.0-linux64-legacy.zip
unzip -o adeptio*.zip
sudo cp -f adeptio-cli adeptiod /usr/bin/

Please don't mix versions: adeptiod-v2.0.0.0-linux64.zip vs adeptiod-v2.0.0.0-linux64-legacy.zip

Linux64 - Ubuntu 18.04 (Bionic Beaver) or corresponding Debian distro;
Linux64 legacy version - Ubuntu 16.04 (Xenial Xerus) or corresponding Debian distro;

Bind your external IP addr in to adeptio.conf. Open the file:

nano ~/.adeptio/adeptio.conf

Add extra line to the config:

bind=YourExternalipHere
enablezeromint=0

If you don't know your external IP. We can use command to parse it:
curl -s 4.ipquail.com/ip

Now save the file.

Start the adeptiod with new version:

sudo systemctl start adeptiocore.service

If you don't have adeptiocore.service use deprecated method:
/usr/bin/adeptiod -daemon

Check the adeptiod version:

adeptio-cli getinfo | grep version

The output should match:

"version": 2000000,
"protocolversion": 70716,
"walletversion": 61000,

Install "storADE" platform:

https://wiki.adeptio.cc/books/storade-setup-guide/page/storade-ubuntu-1604-1804-lts

 

Ubuntu 18.04 LTS procedure:

Stop the adeptiod thought the systemd or kill the process: 

sudo systemctl stop adeptiocore.service && pkill adeptiod

Check if adeptiod stopped:

sudo systemctl status adeptiocore.service && pgrep adeptiod

If the process stopped continue:

cd ~/
rm -f ~/adeptio-cli ~/adeptiod
cp -fr ~/.adeptio/ ~/.adeptio_backup/
wget https://github.com/adeptio-project/adeptio/releases/download/v2.0.0.0/adeptiod-v2.0.0.0-linux64.zip
unzip -o adeptio*.zip
sudo cp -f adeptio-cli adeptiod /usr/bin/

Please don't mix versions: adeptiod-v2.0.0.0-linux64.zip vs adeptiod-v2.0.0.0-linux64-legacy.zip

Linux64 - Ubuntu 18.04 (Bionic Beaver) or corresponding Debian distro;
Linux64 legacy version - Ubuntu 16.04 (Xenial Xerus) or corresponding Debian distro;

Bind your external IP addr in to adeptio.conf. Open the file:

nano ~/.adeptio/adeptio.conf

Add extra line to the config:

bind=YourExternalipHere
enablezeromint=0

If you don't know your external IP. We can use command to parse it:
curl -s 4.ipquail.com/ip

Now save the file.

Start the adeptiod with new version:

sudo systemctl start adeptiocore.service

If you don't have adeptiocore.service use deprecated method:
/usr/bin/adeptiod -daemon

Check the adeptiod version:

adeptio-cli getinfo | grep version

The output should match:

"version": 2000000,
"protocolversion": 70716,
"walletversion": 61000,

Install "storADE" platform:

https://wiki.adeptio.cc/books/storade-setup-guide/page/storade-ubuntu-1604-1804-lts

 

Pool operators:

Make sure to have flag in adeptio.conf - enablezeromint=0

New wallet version for Unix requires libevent-dev dependency. Please install by typing in the terminal:

All new binary can be found in Github - release page:

https://github.com/adeptio-project/adeptio/releases

If you need to compile from scratch. There is a step-by-step procedure for various distributions:

https://wiki.adeptio.cc/books/building-the-wallet

 

Exchanges. Crex24 / BiteBTC:

Make sure to have flag in adeptio.conf - enablezeromint=0

New wallet version for Unix requires libevent-dev dependency. Please install by typing in the terminal:

All new binary can be found in Github - release page:

https://github.com/adeptio-project/adeptio/releases

If you need to compile from scratch. There is a step-by-step procedure for various distributions:

https://wiki.adeptio.cc/books/building-the-wallet

 

Troubleshooting:

My coins disappearing from my wallet?:

This is more likely to happen for HOT masternode operators. But can occur to anyone who running adeptiod (not adeptio-qt) The fastest and clearest method would be load an old wallet v.1.0.0.x and send coins to new wallet v2.0.0.0. Please make sure to test it with small amount for example 0.001 ADE.

This problem occurs due to zerocoin zADE privacy feature. ADE > zADE conversion for non-GUI wallets. This example is from masternode wallet.dat imported to GUI wallet. As we can see Available coins 100080.92 . Total 11199.92 due to zADE conversion. zADE functionality activates at certain block. So you need to recover the funds or wait zADE activation.
To avoid this problem add to your adeptio.confenablezeromint=0

Selection_156.png

Selection_159.png

All other problems register in github at issues tab: https://github.com/adeptio-project/adeptio/issues 

Need additional help? Go to Discord and ask for help.


Revision #55
Created 10 months ago by roothere
Updated 4 months ago by roothere